qdPM Extended
project management software for growth
qdPM Extended based on free version of qdPM and has extended functionality and extra features read more.
Home About What's New? Features Demo Buy Now Translations Bug Report Forum Blog Contact Us

qdPM Ex Failure to run

Moderators: ozeworks, qdPM_Support

<<

LHammonds2

Posts: 3

Joined: Tue May 23, 2017 10:35 am

Post Tue May 23, 2017 11:09 am

qdPM Ex Failure to run

I have installed qdPM a few times without any issue. Recently, an existing site stopped working. I tried installing a fresh site/db and get the same problem. I wonder if qdPM is using some function in PHP that is being used that no longer available.

Details of my web server:
* Ubuntu Server 16.04.2 LTS (4.4.0-78-generic Kernel)
* Apache 2.4.18
* PHP 7.0.15

Details of my database server:
* Ubuntu Server 16.04.2 LTS (4.4.0-78-generic Kernel)
* MariaDB 10.1.23

The creation of the database goes just fine. When I see the main page for the web installer, I give it the database credentials and it installs the database but when I access the main page, it throws a "500 Internal Server Error" error. I have verified that the tables were created from the install process and that the web server can connect (I also have other DB-driven PHP web sites that still work).

There is no data generated in the core/log/* folder.

The Apache error log shows the following when the server throws the 500 error:

[Tue May 23 09:09:52.412210 2017] [http:error] [pid 3938] [client 9.9.9.9:56443] AH02428: Empty response header name, aborting request

This is the related access log entry for the same request that generates the 500 error:

9.9.9.9 - - [23/May/2017:09:09:52 -0500] "GET /index.php HTTP/1.1" 500 788 "-" "Mozilla/5.0 (Windows NT 10.0; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0"

Does this work on other PHP 7 sites or does it only work on PHP 5?

LHammonds
Last edited by LHammonds2 on Tue May 23, 2017 11:40 am, edited 1 time in total.
<<

LHammonds2

Posts: 3

Joined: Tue May 23, 2017 10:35 am

Post Tue May 23, 2017 11:39 am

Re: qdPM Ex Failure to run

UPDATE: I installed qdPM on a server with PHP 5.6.30 and it works. Everything else is exactly the same as the other web server except the PHP version.

So you might want to update the installation notes ( http://qdpm-ex.com/installation-pid-10.html ) and change the PHP requirements to read as follows:

* PHP version >= 5.2.4 and <= 5.6.30

Are there plans to release PHP 7-compatible version of qdPM in the near future?

Thanks,
LHammonds

EDIT #1: I have updated my install notes on how to get this working on Ubuntu Server 16.04
http://hammondslegacy.com/forum/viewtopic.php?f=40&t=222

EDIT #2: The qdPM install notes mentions "PDO drivers: mysql" and not mysqli which is probably the crux of this issue. PHP 7 dropped support for the older mysql drivers in favor of the newer mysqli.
<<

ozeworks

Site Admin

Posts: 266

Joined: Wed Nov 03, 2010 9:06 am

Post Sun Sep 24, 2017 12:14 pm

Re: qdPM Ex Failure to run

qdPM Ex has not been ported to php V7 yet.

We will look at doing it as part of the 4.2 release.
<<

LHammonds2

Posts: 3

Joined: Tue May 23, 2017 10:35 am

Post Wed Oct 04, 2017 2:43 am

Re: qdPM Ex Failure to run

ozeworks wrote:
> qdPM Ex has not been ported to php V7 yet.
>
> We will look at doing it as part of the 4.2 release.
Thanks for the update.

Please update your software requirements to reflect this. Saying "PHP version >= 5.2.4" is inaccurate and could lead to user-frustration trying to make it work on current operating systems that have PHP 7 as the default install version.

LHammonds

Return to Version 4 Installation

Who is online

Users browsing this forum: No registered users and 1 guest

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software.